openwrt-安装软件kernel内核版本低-cannot find dependency kernel

2022-01-26   1,495 次阅读


请注意,本文编写于  113  天前,最后编辑于  113  天前,内容可能已经不具有时效性,请谨慎参考。

给openwrt安装软件的时候,出现提示需要5.10.92的kernel内核版本,然而当前系统版本内核只有5.4.52

0x01 opkg降级安装?

opkg update后,内核是不会升级的。但是相应的kmod模块版本会更新到最新的依赖版本。这时候会出现这种问题。起初,想通过opkg降级安装,但是发现很难找到对应版本的kmod模块安装包。

0x02 升级kernel&下载匹配需要的版本

下载内核更新包,在官网的包库中找到内核更新包,连接:https://downloads.openwrt.org/snapshots/targets/x86/64/packages/

搜索kernel,找到对应版本的安装包
image.png

复制这个包的下载地址或者直接下载下来。
openwrt系统终端里执行:

wget 这个包的下载地址

然后执行opkg install安装这个包。

opkg install xxxx.ipk

之后再次执行uname -a查看内核版本,还是5.4.52,但是安装软件是能正常进行的。固件内核版本,只会在固件升级的时候整体升级版本号。这边只是作为依赖包安装了下。

注:内核只能升级,不能降级,并且软件的版本要与内核版本要完全一致,

Q.E.D.

知识共享署名-非商业性使用-相同方式共享 4.0 国际许可协议

Do what i love and just do it !